Queue and play favorites Issues in 0.8.2

Having trouble installing AmpJuke ?
Check this.

Queue and play favorites Issues in 0.8.2

Postby dcavalier on 09-04-2010 16:05

Nothing goes into the queue either when creating a favorite list, then setting it to go to queue instead of play immediately. It does something for a second or two but when you go to queue nothing is there.

I am now testing with a FRESH version of 0.8.2 - I have completely canned the upgrade and started over. And without making any changes or mods whatsoever, I still cannot import music. I also cannot queue music. The other thing that didn't work is, from the favorites list, when you set the option to play immediately, as opposed to queue, and ask to "play all tracks," the flash player just hangs up. Tracks can only be played one at time.

Again, this is with a completely fresh install.

Has anyone else successfully installed 0.8.2 without all of these bugs?

Thanks.
Darlene
dcavalier
AmpJuke addict
AmpJuke addict
 
Posts: 45
Joined: 31-03-2009 18:37

Re: Queue and play favorites Issues in 0.8.2

Postby Michael on 14-04-2010 14:38

Well...FYI I'm testing out a FRESH version works in relation to installation, scan+import, streaming music as well as a couple of other things...
...each and every time *before* releasing.

Also, I recommend that you be a little more specific about what goes wrong at your end rather than just writing "I still cannot import music" (you don't phone the workshop and just say "My car doesn't work").

I left a message in another thread started by you the other day asking you to drop me an email with credentials for your box, so I can log in and take a look myself in order to at least try and understand what's the problem with your installation. In my humble opinion that's a long stretch for something offered for *free*.

Thanks.

//Michael.
User avatar
Michael
Site Admin
Site Admin
 
Posts: 449
Joined: 03-07-2007 13:46
Location: Denmark

Re: Queue and play favorites Issues in 0.8.2

Postby dcavalier on 14-04-2010 21:17

Dear Michael:

I did not simply state "I still cannot import music." I was making reference to an earlier post that did contain detail, in fact, I think you responded to it (I have to go back and look). That earlier post is more detailed. Apparently you didn't read it.

Second, while I appreciate the offer of logging in with my credentials, you offered. I didn't ask. Not only that but in dealing with issues in a prior version, I thought nothing of this because you also offered this back then, and didn't complain about it. Again, I didn't ask you to do this, you offered.

Yes, it's free, and it works well when it works. And that is appreciated. But I would think if you're offering what you're offering, free or not, you'd appreciate feedback in working out the bugs, which apparently this version has, for me anyway. I asked if anyone else had upgrade issues and no one responded so I still don't know whether my issues are isolated to me or what.

I ended up uploading a "raw" version of the whole script, without any changes or mods, and music will not import - as stated in the detail when I first posted about this - it says it reads 2 files but no music is gets imported. As also stated in that detail, when I had import issues with 0.7.7 I finally discovered after much testing, that the problem wasn't any of the things anyone offered as solution, the problem was that the titles could not be read from within the parent directory where the audio is. The songs had to be IN a folder WITHIN that directory to be recognized and imported by the script. So you see I didn't just simply state "I still can't import music" without first painstakingly posting the detail in another post. If that is the one you responded to regarding asking for my login credentials, then you read that detail so not sure why you'd say that.

Darlene
dcavalier
AmpJuke addict
AmpJuke addict
 
Posts: 45
Joined: 31-03-2009 18:37

Re: Queue and play favorites Issues in 0.8.2

Postby dcavalier on 14-04-2010 21:23

By the way, in case this helps anyone else. The songs are in the 0.8.2 version if you log in to the upgrade version, but I had to go to 0.7.7 to use that to import, then sign back into the new version.


Thanks. Darlene
dcavalier
AmpJuke addict
AmpJuke addict
 
Posts: 45
Joined: 31-03-2009 18:37

Re: Queue and play favorites Issues in 0.8.2

Postby Michael on 14-04-2010 22:10

Hi Darlene,

OK. I understand. Didn't want to offend you. If I did: Sorry.

I'm just trying to make something available that's supposed to work right out of the box.
...and I do actually test it pretty much before releasing a new version.

Back on track: How do we make any progress to get the goddamned script working ?
Think my frustrations are based on the fact that I need details/facts/error messages/screenshots/whatever, and then I'll be happy to help you out, if I can.

You mentioned you started all over again using a fresh installation of 0.8.2.
Did it work ok ? Did you follow the installation example ?
Are you using your own server or is the stuff hosted with an ISP ?
Assuming installation is ok: Do you get any error messages when doing a scan+import ?

//Michael.
User avatar
Michael
Site Admin
Site Admin
 
Posts: 449
Joined: 03-07-2007 13:46
Location: Denmark

Re: Queue and play favorites Issues in 0.8.2

Postby dcavalier on 14-04-2010 23:27

Michael wrote:Hi Darlene,

OK. I understand. Didn't want to offend you. If I did: Sorry.


No offense taken. Just don't usually get those responses from you. Thinking maybe my excessive posting stuck in your craw. :roll:

Think my frustrations are based on the fact that I need details/facts/error messages/screenshots/whatever, and then I'll be happy to help you out, if I can.


So right out of the box, I can't import. The message I get when I try to import is that it reads two folders but there are not tracks being read. As I said I did end up importing from the old 0.7.7 version just to get them in, and they are there once I then sign into the upgrade version 0.8.2. I've tried moving all the songs, which were in a sub directory (because that's the only way it would work in 0.7.7) into the main song directory. Still nothing.

Here's what I get when I try importing from the raw upload of 0.8.2:

Note: Bery very, very patient ! This might take a long time.
Build list of folders...
Not able to read from:
Not able to read from:
Scan+import tracks in folder: /home2/oneegnet/public_html/songreel/songreeldbaudio/
Finished !
Build+display report...
Reports finished. Add totals...
Get contents of each "sub-report". Include in main report
Report: Folders not read...
Report: New tracks found...
Report: Warnings...
Report: Errors...
Report: Re-processed tracks...
Clean up...
Scan+import finished. There is a report as well in: /home2/oneegnet/public_html/songreel/sr082/tmp/scan_report_1271277467.htm
Click here to view (it will open in a new window)

The script is hosted by the same ISP that I run 0.7.7, which works fine.

Here is the printout of the report.

*** SCAN REPORT ***
*** Settings ***
Complain about missing permissions on folders: Yes
Delete "dead" records:No
Active cutoff date:No
Skip tracks w. low bitrate:No
Re-process tracks found in database and on filesystem:No
Simulate import: No
Missing tag in track number is: OK
Missing tag in year is: OK
Missing tag in album name is: OK
Missing tag in performer name is: OK
Missing tag in track name is: an error
Import warnings: No
Import errors: No
*** Totals ***
Number of folders: 2
Number of folders not read: 0
Number of tracks: 0
Number of new tracks: 0
Number of tracks not read: 0
Warnings: 0
Errors: 0
Number of tracks re-processed: 0
*** Folders not read ***
Folders that cannot be read: 0
*** New tracks ***
Number of new tracks discovered: 0
*** Warnings ***
Total warnings: 0
*** Errors ***
Total errors: 0
*** Reprocessed tracks ***
Number of tracks re-processed: 0

It's probably something so simple and I'm just a doh-doh.
Thanks again. Darlene
dcavalier
AmpJuke addict
AmpJuke addict
 
Posts: 45
Joined: 31-03-2009 18:37

Re: Queue and play favorites Issues in 0.8.2

Postby Michael on 15-04-2010 17:46

No offense taken. Just don't usually get those responses from you.

Thanks. And thanks again.
Just been under a lot of pressure lately, - mostly @ work. Feels like I'm a couple of hours late every time. Stuff piles up. That's OK for a short period of time, but if it lasts too long, then: :x (hell..."I'm only human" as Human League mentions on "Human"...).
Anyway, things are bound to get a little brighter, - at least I hope :wink:

Enough whining about my currently pathetic work/life balance.
Based on the scan-report you posted, I think your problem is based on the good 'ol permission-problem...
You should check the permissions on the folder songreeldbaudio.

Yes, up until version 0.8.0 it was not possible to scan any music from the "base" folder (in your case songreeldbaudio, I assume), but only from subfolders within that (in your case songreeldbaudio/someotherfolder).
However that changed with 0.8.0.

Please also remember that permissions for each track within any folder should be "enough" (777, or rwxrwxrwx will definately be "enough"). The reason ? The 'web-user' the script is running as, must deal with "things" (folders and music-tracks) on the filesystem and must be able to read from these things.
More here http://www.ampjuke.org/faq.php?q_id=12.

You could turn on "complain about missing permissions" when setting up a scan+import in order to verify that permissions are as expected.

Hope this helps. Please update with whatever progress you make.

//Michael.
User avatar
Michael
Site Admin
Site Admin
 
Posts: 449
Joined: 03-07-2007 13:46
Location: Denmark

Re: Queue and play favorites Issues in 0.8.2

Postby dcavalier on 15-04-2010 19:12

Yeah well I'm human too, and human enough to be embarrassed about what the issue was.

When I did the new upload of 082, I had the name of the destination of the audio directory wrong! OMG. Everyone check the spelling of your directories first before troubleshooting everything else under the sun.

Now onto the favorites issue and that should do it for me...

Lord. Sorry. I knew it was going to be something really dumb like that. I'm officially a moron.

Darlene
dcavalier
AmpJuke addict
AmpJuke addict
 
Posts: 45
Joined: 31-03-2009 18:37

Re: Queue and play favorites Issues in 0.8.2

Postby dcavalier on 15-04-2010 19:13

p.s. Michael the work/life balance is an acquired skill for us workaholics. Something I haven't mastered yet.

Good luck with that one! Let me know if you have any tips.

Darlene
dcavalier
AmpJuke addict
AmpJuke addict
 
Posts: 45
Joined: 31-03-2009 18:37

Re: Queue and play favorites Issues in 0.8.2

Postby Michael on 16-04-2010 09:41

I'm officially a moron.

I have to disagree with that. If people in general had the dignity to admit they've made a mistake, the world would be a much much better place.
...anyway, your post left a grin on my face. Which is a great achievement these days.

Great you're back in business (almost, still the favorite-thing outstanding from your other post).

//Michael.

P.S.: Happy I'm not the only one who scr*ws up work/life from time to time.
I'll let you know if/when I come across some tips...
...other than a couple of glasses of decent red wine plus listening to some music streamed by AmpJuke, of course :wink:
User avatar
Michael
Site Admin
Site Admin
 
Posts: 449
Joined: 03-07-2007 13:46
Location: Denmark

Re: Queue and play favorites Issues in 0.8.2

Postby dcavalier on 16-04-2010 10:00

Re: red wine. Actually cracked open a bottle of Franciscan Oakville cab from Napa Valley CA. Reasonably priced at only $25 USD it's a great way to end the day. The Magnificat runs around $50... Still reasonably priced for a decent bottle.

I'll be working out the favorites thing over the next few days. Maybe its something simple like i have to plug on the internet... :P

Thanks again.
Darlene
dcavalier
AmpJuke addict
AmpJuke addict
 
Posts: 45
Joined: 31-03-2009 18:37


Return to Installation / support

Who is online

Users browsing this forum: No registered users and 2 guests

cron