Installation done...now receiving errors play songs

Having trouble installing AmpJuke ?
Check this.

Installation done...now receiving errors play songs

Postby bigblue on 14-07-2007 08:05

Please help! Here's are the warning strings I receive when I attempt to play one of the newly imported songs. Note: I have substituted my domain alias below with the 'xxxxx'. Thanks for any help :)

Warning: fopen(./tmp/admin.m3u): failed to open stream: Permission denied in /home/xxxxx/public_html/stream/play_action.php on line 65

Warning: fwrite(): supplied argument is not a valid stream resource in /home/xxxxx/public_html/stream/disp.php on line 402

Warning: fwrite(): supplied argument is not a valid stream resource in /home/xxxxx/public_html/stream/disp.php on line 404

Warning: fwrite(): supplied argument is not a valid stream resource in /home/xxxxx/public_html/stream/disp.php on line 405

Warning: fwrite(): supplied argument is not a valid stream resource in /home/xxxxx/public_html/stream/disp.php on line 404

Warning: fwrite(): supplied argument is not a valid stream resource in /home/xxxxx/public_html/stream/disp.php on line 405

Warning: fclose(): supplied argument is not a valid stream resource in /home/xxxxx/public_html/stream/play_action.php on line 175

Warning: Cannot modify header information - headers already sent by (output started at /home/xxxxx/public_html/stream/play_action.php:65) in /home/xxxxx/public_html/stream/play_action.php on line 178
bigblue
Newbie
Newbie
 
Posts: 2
Joined: 14-07-2007 07:59

Probably permissions...

Postby Michael on 14-07-2007 10:12

Thanks for the detailed error description - it helps a lot !

The first warning:
Warning: fopen(./tmp/admin.m3u): failed to open stream: Permission denied in /home/xxxxx/public_html/stream/play_action.php on line 65

...is most likely because the 'web user' doesn't have full permissions (that is: read/write/execute) within the directory: /home/xxxxx/public_html/stream/tmp

There are a lot of ways you can change it: using 'chmod' in a terminal, using some kind of FTP-program etc.
If you're using something like FireFTP, here's an example of how to set permissions to 777 (full access for owner, group and everybody else):
Image
You should do that for the directories/folders 'tmp' and 'covers' - 'covers' is only interesting if you have configured AmpJuke to use the Amazon webservice to retrieve covers.


All other warnings - apart from the last - are related to the 'missing' permission setting.


The last warning:
Warning: Cannot modify header information - headers already sent by (output started at /home/xxxxx/public_html/stream/play_action.php:65) in /home/xxxxx/public_html/stream/play_action.php on line 178

...might be because your browser have blocked pop-ups for the site where AmpJuke is installed.
If you allow pop-ups for the site in question, everything should be OK.

In the next release (0.6.1 - will be available July 26th) there will be checked for 'correct' permissions in various places (incl. 'tmp') during installation.

Let me (the forum) know if you run into any trouble in relation to this.

//Michael.
User avatar
Michael
Site Admin
Site Admin
 
Posts: 449
Joined: 03-07-2007 13:46
Location: Denmark

Yes...that did it!!! Thank you...

Postby bigblue on 14-07-2007 10:40

After setting the permissions to 777 on the /tmp directory, everything is working perfectly. I appreciate your quick response. Cheers :D
bigblue
Newbie
Newbie
 
Posts: 2
Joined: 14-07-2007 07:59

Postby Michael on 16-07-2007 20:52

...and thanks a lot for your time to make a feedback !

It's nice to know when things happen to work as expected after a 'tweak' :wink:

//Michael.
User avatar
Michael
Site Admin
Site Admin
 
Posts: 449
Joined: 03-07-2007 13:46
Location: Denmark

Fopen errors

Postby aztec105 on 22-07-2007 03:48

Hello Michael here is something else to check for fopen errors

by default my php5.ini had this set to off


;;;;;;;;;;;;;;;;;;
; Fopen wrappers ;
;;;;;;;;;;;;;;;;;;

; Whether to allow the treatment of URLs (like http:// or ftp://) as files.
allow_url_fopen = On
In the land of the blind the one eyed man is King
User avatar
aztec105
Newbie
Newbie
 
Posts: 7
Joined: 12-07-2007 03:25
Location: Ottawa ontario

Re: Installation done...now receiving errors play songs

Postby micheal45631 on 25-01-2011 14:31

Could you tell me more … I would love to explore.
micheal45631
Newbie
Newbie
 
Posts: 1
Joined: 25-01-2011 13:43


Return to Installation / support

Who is online

Users browsing this forum: No registered users and 1 guest

cron