Recent Posts

Pages: 1 2 3 4 5 [6] 7 8 9
51
Support / Re: Permission issues even after pre-install says 'OK'
« Last post by Michael on 08-04-2013 20:36 »
Hello feonil,

Thanks for posting and welcome to the AmpJuke forum.

Yes - the quickest might be to reinstall.

However, it seems like the permissions wasn't set as expected (even though you got an OK for everything), - I'm a bit confused about that  ???
Based on your post, it seems to me that you're installing in /ampjuke-0.8.6/... shouldn't it be something like /var/www/ampjuke-0.8.6/... ?
It's the HTTP-location... (step 2+3 in the install-guide: http://www.ampjuke.org/?id=installation). I would double check that and do a fresh install.

Apart from that suggestion I cannot think of any other source of error, - again: based on what you wrote.

Hope this helps. If not, please don't hestitate to post an update (well...feel free to do so in any case).

//Michael.
52
Support / Permission issues even after pre-install says 'OK'
« Last post by feonil on 07-04-2013 06:23 »
Tried scriptaculous/cPanel install.
Got 'permission' error on setup.

Tried again with manual install.
Got 'OK to install' from setup script.
When I click 'Save' on config page however, I get:
   Forbidden ... You don't have permission to access /ampjuke-0.8.6/sitecfg.php on this server.
   Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Changed permissions on suggested files/folders to 777 per screenshots in example.
Same permissions error on sitecfg.php

Changing permissions on sitecfg to 777 does not help either.

From what I can see in the log ...
The referring URL is : http://sub.domain.com/ampjuke-0.8.6/sitecfg.php?uuid=./tmp/69f717c2-a3fa-ab57-4c04-da55d7aae3c6.tmp
The offended URL is : http://sub.domain.com/ampjuke-0.8.6/sitecfg.php?act=store

So it is saying that ./tmp/*.tmp does not exist/cannot be found/cannot be accessed (403/404) ?

Cannot re-trace my steps either. I get a 500 error. So will need to install a fresh copy ?
53
Support / Re: Permission Problems
« Last post by amp-z0r3d on 22-11-2012 22:45 »
Sorry, I don't. Either no error is logged on a permission error, or I don't have access to them. I do get error.log generated in my home dir when a php error or warning is generated, like this little gem on the signup page which sunk my hopes of asking my friends to sign up:

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/polyash/public_html/greenfreedom/ampjuke-0.8.6/userreg.php:4) in /home/polyash/public_html/greenfreedom/ampjuke-0.8.6/userreg.php on line 23
EDIT: maybe I can fix this in PHP.INI

Say, I'm guessing you have tons of more interesting things to do than debug my AmpJuke installation. Perhaps you are in need of administrative access to another sandbox? After seeing you give away to the public a body of work this size I feel really guilty about asking you for help without offering a sizable bribe. There is a whole list of these kind of things for me to solve before I can use it for its intended design purpose, but wow, it is just so damn cool.

And by the way, that human verification thing on the signup page is very cool.

54
This is a non-issue. I'm an idiot. I did a number of installs, and some odd display issues were related to not clearing my cookies.
55
The admin panel is supposed to show up on the "welcome" page when you login as an administrator...
...it's checked against the active session (which again get some of it's settings from the database).

Take a look around line 460 in index.php.

//Michael.

56
Support / Re: Permission Problems
« Last post by Michael on 18-11-2012 11:14 »
Well...I just cannot reproduce that on my own box.  :(

Downloaded, installed, scanned+imported music and finally did a "Scan metadata...".

After that, I picked some albums, asked for a new cover, clicked on one of the results from Google or last.fm...
...and it worked as expected.

One thing I'm very puzzled about is the fact that you cannot do anything - even with 777 set on all relevant directories.

Do you have an error log (/var/log/apache2/error.log) I can take a look at ?

//Michael.
57
Support / Re: Permission Problems
« Last post by amp-z0r3d on 17-11-2012 05:37 »
I'm having the same problem here when trying to look up a new image for an album or performer. The auto downloaded images aren't always correct, but when I try to do it manually, and click on an image from last.fm or google, I get:

You don't have permission to access /ampjuke-0.8.6/index.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Now, this is after a successful install, configuration, and while listening to tracks. :)
So, I changed all the permissions of the folders mentioned above to 777. Tmp, covers, lastfm, and top tags to 777. Setup php is gone of course. By the way, changing the install directory to 777 caused an error, nothing works after I do that.
58
Thanks. I have installed VLC which works very nicely. I don't know why ZOOM (free version) didn't work even with it properly associated with .m3u files. grr.

By the way, I noticed one little thing when I was playing with user options as administrator.
I'm not sure if this is by design or not, but when you open the user administration panel (as admin user) the admin options panel disappears, and doesn't reappear until you login again. I guess that is for security in case some admin options are changed?
59
Thanks for the feedback.
Hey - admitting an error is (in my opinion) a really great personal ability!

It doesn't like the links...? Hmm... can I offer some help in relation to that ?
They are ordinary m3u-files, unless you're using flash: then it's xspf.
I've tested m3u against Winamp, VLC (my favorite), Media player ('cause some people are still using it, apparently) as well as a range Linux-players (Gnome mplayer, movie player etc.).

If you need to investigate the m3u-playlist, it will be stored in your /path/to/ampjuke/tmp/<username>.m3u before being sent to the client. It will only be there for a relatively short duration.

By the way: Pop-ups should be allowed from your server.

//Michael.
60
I feel so stupid now. I did try out that getcwd thing and it worked, but it did not give me a different dir structure. After playing with it a while I figured out I had inadvertently put a space before the leading slash in the music path in configuration options. Ok, so that's progress. Now at least I can graduate to a different kind of error. Now the scan tool really works and I have successfully added Performers, Tracks, and Albums. I haven't gotten anything to play quite yet because my player doesn't seem to like the stream links very much, but I'm very pleased with the progress thus far, and having fun playing with it. Thanks for your help.

I guess the upshot is, there really is no problem that I can see with running under Cpanel. My problems are clearly related to um...something else.
Pages: 1 2 3 4 5 [6] 7 8 9